Subject: Another odd bounce / BDAT

From: Ralf Baechle <[email-masked]>
Date: Wed, 18 Dec 2002 23:52:11 +0100

The email of one of my users is bouncing with this error message:

[...]
  Diagnostic texts:
      <<- MAIL From:<[email-masked]> SIZE=941
     ->> 250 Requested mail action okay, completed
     <<- RCPT To:<[email-masked]>
     ->> 250 Requested mail action okay, completed
     <<- BDAT 943 LAST
     ->> 500 Syntax error, command unrecognized
[...]

So what's BDAT?

  Ralf
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Thu, 19 Dec 2002 00:44:52 +0100

> So what's BDAT?

RFC 1830. A failed extension meant to replace DATA for efficient 
transmission of 8-bit data. Didn't catch on.

Very few SMTP clients and servers support it, so it won't be well 
tested. I suggest that you simply rip the support out of your zmailer.

--Arnt
-

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 19 Dec 2002 15:49:17 +0100

> transmission of 8-bit data. Didn't catch on.

Ah...  Thanks for the pointer.

> tested. I suggest that you simply rip the support out of your zmailer.

The remote side is advertising it's chunking capability and then rejects
a BDAT command.  Looks like a broken firewall.  Easy fix for me, let the
remote side deal with their own crap.

  Ralf
-