Subject: Possibly a silly question.

From: alvin <[email-masked]>
Date: Thu, 29 Aug 2002 14:57:13 -0400

Why does the router read the message headers?

I just ran into a router core dump issue with a stupidly formated
message have been assured that postfix does not touch the headers so why
should zmailer. 

I took a quick brows through the docs but did not see anything obvious.

-- 
Alvin Starr                   ||   voice: (416)785-4051
Interlink Connectivity        ||   fax:   (416)785-3668
[email-masked]              ||
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Matti Aarnio <[email-masked]>
Date: Thu, 29 Aug 2002 22:15:20 +0300

> Why does the router read the message headers?

  - "/usr/lib/sendmail -t"  means that the router needs to
    pick recipient addresses from  To:, Cc: and Bcc: headers.

  - Also the RFC 822/2822 does say that outgoing addresses
    in visible headers must have FQDN addresses

  - Sometimes it is desired to rewrite user addresses, e.g.:
    From:
       From: Matti Aarnio <[email-masked]>
    To:
       From: Matti Aarnio <[email-masked]>
 
> message have been assured that postfix does not touch the headers
> so why should zmailer. 

  That is indicative of broken code.  Nothing such should happen...
  Could you send me the original Bad Message ?
  (Its header block.)

-- 
/Matti Aarnio	<[email-masked]>
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]