Subject: RE: local user capitalization problem.

From: Crispin Bivans <[email-masked]>
Date: Mon, 21 Jan 2002 12:00:21 -0600

A possible workaround for your situation would be to create a 2nd user with
the same unix UID in a lowercase version.. It would be a bit of deception
that may 'work' while still allowing those users to use their Mixed case
user. Some unix commands may return the lowercase name (it'd have to be
tested) but definitely the 'forward' lookups on username to uid should work.

But in general the much easier thing would be to eliminate those mixed case
names.

-Crispin

		-----Original Message-----
		From:	Andy Poling [mailto:[email-masked]]
		Sent:	Monday, January 21, 2002 11:51 AM
		To:	Johnathan Thibodeau
		Cc:	[email-masked]
		Subject:	Re: local user capitalization problem.

		On Mon, 21 Jan 2002, Johnathan Thibodeau wrote:
		> Now, it would be nice if all our users had lower case
names, but sadly we
		> let them choose their own name on occasion. And despite
any persuasion to
		> so otherwise, they sometime choose a name with capital
letters.

		Just say no.  You'll have no end of headaches.

		Email addresses are (practically-speaking) case-insensitive,
and you cannot
		easily deal with that if your usernames are mixed case.

		Force them all to all lower-case, and eliminate future
headaches...

		-Andy
		
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Johnathan Thibodeau <[email-masked]>
Date: Mon, 21 Jan 2002 15:01:54 -0400 (AST)

> tested) but definitely the 'forward' lookups on username to uid should work.

I'm not sure how our popper would react to this. Plus, there are ~200 bash
scripts that modify the password file to do all the account processing.
Finding them all would be a lifes work. (Well, maybe not 200, but you get
my point. Hey, I didn't write the system.)

> But in general the much easier thing would be to eliminate those mixed case

That's about 100 emails I would rather not send out.

Our current version (2.99.50-s19) does all this perfectally fine, so I
figured it was just a hidden configuration variable that I missed
somewhere. This is starting to look like a source code modification. Fun.

Johnathan Thibodeau
Chebucto Community Net

-