Subject: daemonsub.c

From: Eugene Crosser <[email-masked]>
Date: 04 Oct 2002 20:51:59 +0400

Once it uses wait() it needs wait headers:

Index: router/daemonsub.c
===================================================================
RCS file: /cvsroot/zmailer/router/daemonsub.c,v
retrieving revision 1.15
diff -u -r1.15 daemonsub.c
--- router/daemonsub.c  2002/10/04 14:50:55     1.15
+++ router/daemonsub.c  2002/10/04 16:50:31
@@ -26,6 +26,27 @@
 #include <sys/un.h>
 #endif
 
+#ifdef  HAVE_WAITPID
+# include <sys/wait.h>
+#else
+# ifdef HAVE_WAIT3
+#  include <sys/wait.h> /* Has BSD wait3() */
+# else
+#  ifdef HAVE_SYS_WAIT_H /* POSIX.1 compatible */
+#   include <sys/wait.h>
+#  else /* Not POSIX.1 compatible, lets fake it.. */
+extern int wait();
+#  endif
+# endif
+#endif
+
+#ifndef WEXITSTATUS
+# define WEXITSTATUS(s) (((s) >> 8) & 0377)
+#endif
+#ifndef WSIGNALSTATUS
+# define WSIGNALSTATUS(s) ((s) & 0177)
+#endif
+
 #include "zsyslog.h"
 #include "shmmib.h"
 #include "sysexits.h"

-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Matti Aarnio <[email-masked]>
Date: Sat, 5 Oct 2002 00:34:57 +0300

> Once it uses wait() it needs wait headers:

  The   #include "zmsignal.h"   should handle this..
  At least it handles in my RedHat rawhide system.

  Do you, by change, have a file with that name somewhere
  in your system ?

-- 
/Matti Aarnio	<[email-masked]>
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Eugene Crosser <[email-masked]>
Date: 07 Oct 2002 14:23:52 +0400

>   Do you, by change, have a file with that name somewhere

Oops, I did not update zmsignal.h from CVS, sorry...

Eugene

-