Subject: Re: MAIL FROM discarded

From: Szymon Juraszczyk <[email-masked]>
Date: Tue, 1 Jan 2002 04:21:43 +0100

On Mon, 2001-12-10 at 14:57:50, [email-masked] wrote:

> I have server with zmailer.
> >From this server I send with my perl script mail to this local
> Zmailer...
> 
> HELO localhost
> MAIL FROM: <[email-masked]>
> RCPT TO: <[email-masked]>
> DATA
> Subject: Potvrzeni registrace
> From: Potvrzovadlo <[email-masked]>
> To: Prihlasovatel <[email-masked]>
> X-pomucka: blabla
> bla bla bla
> QUIT
> 
> This all is OK. Zmailer receive this from my script, but!
> 
> When Zmailer sending this mail to shaana, this mail have envelope
> MAIL FROM: <>, and shaana's SMTP server is configured to not receive
> mail with empty MAIL FROM:.
> 
> Why Zmailer discard my MAIL FROM?

  I had the same problem when I used a 'hack' to reject nonexistent users
in virtual domains, putting

a.domain.com	error!nosuchuser

  in /etc/zmailer/db/routes file. There's a piece of code in Zmailer that
breaks MAIL FROM addresses when it thinks they are comming from 'error'
channel.

  If this is what you do, I can give you solution to this problem.

Regards,
-- 
Szymon Juraszczyk, [email-masked]
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Szymon Juraszczyk <[email-masked]>
Date: Tue, 1 Jan 2002 13:52:37 +0100

On Tue, 2002-01-01 at 12:22:03, Petr Klimovic wrote:

> SJ>   in /etc/zmailer/db/routes file. There's a piece of code in Zmailer that
> SJ> breaks MAIL FROM addresses when it thinks they are comming from 'error'
> SJ> channel.
> 
> SJ>   If this is what you do, I can give you solution to this problem.
> 
> Prosze o rozvionzanie.
> Yes, I want this solution, please.

  I simply use a diffrent channel name:

domain.com.pl        notfound!address_does_not_exist

  which I defined in scheduler.conf:

notfound/*
	interval=5m
	idlemax=2m
	maxchannel=5
	command="errormail -c notfound"

Regards,