Subject: Contentfilter problem CD

From: Adrian Siemieniak <[email-masked]>
Date: Mon, 14 Oct 2002 16:08:59 +0200

Hello - i still haven't found any solution - can't anybody realy help
me with that problem? ;)

Few more clues -
when smtpserver is run with "-i" (interactive) IT WORKS FINE!

when run as a daemon or from inetd i have error like before
--
HWP009672r      data
HWP009672w      354 Start mail input; end with <CRLF>.<CRLF>
HWP009672#      policyprogram said: ÿ
HWP009672#      policyprogram said: 
HWP009672#      Content-policy analysis ordered message rejection.
(code=-1); ms g=''
HWP009672w      552 5.7.1 
--

The policy program is good for sure (since it writes only 0 520 as an
anwser)

strace put on smtpserver sais (cos is a name of policy program):
---
[pid  2195] execve("/zmailer/mailbin/cos", ["/zmailer/mailbin/cos"], [/*
20 vars */]) = 0
[pid  2195] uname({sys="Linux", node="sun", ...}) = 0
[pid  2195] brk(0)                      = 0x80495d4
...
[pid  2194] close(7)                    = 0
[pid  2194] write(9, "/zmailer/postoffice/public/sun.i"..., 47) = 47
[pid  2194] read(6,  <unfinished ...>
[pid  2195] <... nanosleep resumed> {5, 0}) = 0
[pid  2195] write(1, "0 520 OK\n", 9)   = 9
[pid  2195] munmap(0x40128000, 4096)    = 0
[pid  2195] _exit(0)                    = ?
[pid  2194] <... read resumed> 0x401f1000, 4096) = ? ERESTARTSYS (To be
restarte d)
[pid  2194] --- SIGCHLD (Child exited) ---
[pid  2194] wait4(-1, [WIFEXITED(s) && WEXITSTATUS(s) == 0], WNOHANG,
NULL) = 21 95
[pid  2194] wait4(-1, 0xbfff7de8, WNOHANG, NULL) = -1 ECHILD (No child
processes)
[pid  2194] rt_sigaction(SIGCHLD, {0x804cc6c, [],
SA_INTERRUPT|SA_NOMASK|0x40000 00}, NULL, 8) = 0
[pid  2194] sigreturn()                 = ? (mask now [])
[pid  2194] write(3, "NN4M02194#\tpolicyprogram said: \377"..., 33) = 33
[pid  2194] close(9)                    = 0
[pid  2194] munmap(0x401f0000, 4096)    = 0
[pid  2194] write(3, "NN4M02194#\tpolicyprogram said: \n", 32) = 32
---

Both smtpserver and policyprogram are owner by root and run on it
(zmailers runs on chrooted environment with it's own libraries etc.)

If ANYONE have ANY clue - PLEASE help!

Pozdrawiam
--
Adrian Siemieniak | Administrator (at) Internet Center Polska
sauron(at)icenter.pl
tel. (0-71) 344-82-53 wew 26
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Dirk Munzinger <[email-masked]>
Date: Wed, 16 Oct 2002 20:59:32 +0200

Hi,

> when run as a daemon or from inetd i have error like before

This looks like that zmailer can not execute the contenfilter script. 
Maybe the user running zmailer does not have the right to execute or 
maybe the script doese not have acces rights to a file (mail, 
filterlist, logfile)

Regards, Dirk

-