Subject: router.cf ?

From: Tomasz Nowak <[email-masked]>
Date: Tue, 30 Jul 2002 22:27:34 +0200

Hi,

  I would like to make something like that:

  smtpserver puts mails into directory dir1.
  router gets mails from directory dir2.
  dir1 is not equal dir2.

  The standard configuration is dir1 = dir2 = $POSTOFFICE/router

Best regards
--
Tomasz Nowak     TRIGER - Systemy Komputerowe   http://www.triger.com.pl
 Oferujemy m.in.  H@NDEL - Twój krok w nową erę sprzedaży w Internecie,
  usługi WebDesign, bezpieczne konta WWW, Email. Sprawdź nas już dziś.

-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Matti Aarnio <[email-masked]>
Date: Wed, 31 Jul 2002 14:02:59 +0300

>   router gets mails from directory dir2.

  Presuming you want _only_ the smtpserver input to be placed into separate
  queue directory, you could modify   smtpserver/smtpdata.c  at places,
  where  _mail_close_()  are called.  What you want is to replace that
  with mail_close_alternate() feeding the messages into separate directory.
  You will notice that the API of the calls are different..

  Anyway, I _think_ you are trying to run some scanner on every
  message before it becomes routed ?

  You can run arbitrary program from router for each message, see
  router script   proto/cf/process.cf:

	case "$file" in
#	[0-9]*.x400)	x400 "$file" ;;
#	[0-9]*.uucp)	uucpfilter "$file" > /tmp/X.$$
#			cat /tmp/X.$$ > "$file"
#			rfc822 "$file" ;;
	[0-9]*)		rfc822 "$file" ;;
	core*)		/bin/mv "$file" ../$file.router.$$
			return
			;;
	*)		/bin/mv "$file" ../postman/rtr."$file".$$
			return
			;;
	esac

  Normally we run builtin 'rfc822' function ( router/sequencer.c ),
  which does all the work, but see how files with ".uucp" suffix
  could be handled...

>  Oferujemy m.in.  H@NDEL - Twój krok w now? er? sprzeda?y w Internecie,
-- 
/Matti Aarnio	<[email-masked]>
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Eugene Crosser <[email-masked]>
Date: 31 Jul 2002 15:38:02 +0400

>   You will notice that the API of the calls are different..

I think the same can be accomplished by creating a separate $POSTOFFICE
(which will need only "public" and "router" subdirectories) and running
smtpserver with "-P <postoffice>" option...

Eugene

-