Subject: message size limitations

From: "Marek Kowal" <[email-masked]>
Date: Wed, 2 Oct 2002 17:27:08 +0200

Hi there,

I would like to vary maximum message size allowed by the smtp server based
on the login of the sender from envelope address. The problem is, this quota
is advertised by server after EHLO command, before MAIL FROM: command. Of
course, I could advertise some big number there and refuse to process mail
after "." from DATA command, but this will make users angry - first they
will send huge mail over slow modem link for several minutes, and then they
will be informed, that we are sorry etc... And the so called "user's
positive experience" is an important issue for us and we'd rather not
proceed in this direction.

Is there any way to force/advise client to send actual message size intended
to be transmitted before DATA command, but after MAIL FROM: <>?

Obviously, my main concern are Outlook Express clients, as they tend to be
in biggest abundance out there in the real world ;-) Such cooperation from
other relays would be feasible, but is not cruicial - i.e. I will loose some
bandwidth, but at least the user will not wait, just the other server.

Let me know, if you have any advices or experiences with that issue.

Cheers,
Marek.

--
Bus error -- passengers dumped.

-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Matti Aarnio <[email-masked]>
Date: Wed, 2 Oct 2002 19:36:09 +0300

> on the login of the sender from envelope address. The problem is, this quota

  The "login" you can get by doing AUTH, the MAIL FROM carried address
  makes no guarantee of anything.

  Once upon a time I did consider adding code to be able to parametrize
  the SIZE-limit value by source IP address.  (E.g. your dialup pools..)
  Oh.. There is even code, lots of it..

  The documentation is -- lacking.  Fix into  doc/guides/smtp-policy,
  and pasting here relevant passage:

	- smtp-policy.relay.manual
	- smtp-policy.relay
			Who can use us as outbound relay.

			Use here
				[ip.number]/maskwidth
			for listing those senders (networks) we
			absolutely trust.  Additionally you may give
			(at the same line) some attributes as parameters
			for this key entry:
				fulltrustnet +
				trustrecipient +
				maxinsize 30000000

			The first pair will accept any source address,
			and any recipient addresses that are fed to
			the server.

			The second will verify the source IP-address,
			but after that it will accept any recipient
			addresses.

			The third pair sets EHLO-reported "SIZE nn"
			parameter to be limited to 30 million bytes.
			(Or to global definition, if that is in range
			 of 1 thru 'nn'-1.)

   The parameter usage is purely advisorial.  It is used when formulating
   the EHLO response, not when checking e.g. MAIL FROM:<..> SIZE=
   parameter.

> to be transmitted before DATA command, but after MAIL FROM: <>?

IF the client looks for EHLO reported SIZE value, then this technique can
be used to control the thing.  If not..  A code change is then (perhaps)
needed.

Of course the OE won't explain the remote system refusal in any
understandable way, which will cause your users to grieve more..

> bandwidth, but at least the user will not wait, just the other server.

... however that is the pickle we all are in, OE is moron.

-- 
/Matti Aarnio	<[email-masked]>
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: James MacKinnon <[email-masked]>
Date: Wed, 2 Oct 2002 11:08:30 -0600 (MDT)

Hi Matti,

Is there a prescription to protect zmailer/lists/ files from spam
abuse?

ie to allow only hosts in the local domain zmailer runs under to
send to a list address, or to have a restricted list of users allowed
to send to the list?

Thanks,
--
James S. MacKinnon           Office: P-139 Avadh-Bhatia Physics Lab
Team Physics                 Voice : (780) 492-8226 [old AC 403]
University of Alberta        email : [email-masked]
Edmonton, Canada T6G 2N5     WWW   : http://www.phys.ualberta.ca/

for all that we know the universe could cease to exist at any mo

-

---

From: Matti Aarnio <[email-masked]>
Date: Fri, 4 Oct 2002 16:09:23 +0300

On Wed, Oct 02, 2002 at 11:08:30AM -0600, James MacKinnon wrote:
> Date:	Wed, 2 Oct 2002 11:08:30 -0600 (MDT)
> From:	James MacKinnon <[email-masked]>
> To:	[email-masked]
> Subject: zmailer lists protection
> 
> Hi Matti,
> 

  Yes.  Majordomo  (or any other list-manager).

> send to a list address, or to have a restricted list of users allowed

  No, nothing inherent in the ZMailer MTA itself.

  It is sad, but the time of general opennes of
  various alias-like lists is long gone :-(

---

From: James MacKinnon <[email-masked]>
Date: Sun, 6 Oct 2002 16:26:13 -0600 (MDT)

Hi Matti,

resync'ed to the cvs again today, but still having trouble with the 
zmailer CVS source build:

...
making all in smtpserver
make[1]: Entering directory 
`/usr/local/src/zmailer-cvs/zmailer/smtpserver'
gcc -g -O2  -DHAVE_CONFIG_H -I./../include -I../include -I..   -c 
smtpserver.c
gcc -g -O2  -DHAVE_CONFIG_H -I./../include -I../include -I..   -c 
rfc821scn.c
gcc -g -O2  -DHAVE_CONFIG_H -I./../include -I../include -I..   -c 
debugreport.c
gcc -g -O2  -DHAVE_CONFIG_H -I./../include -I../include -I..   -c 
fdstatfs.c
gcc -g -O2  -DHAVE_CONFIG_H -I./../include -I../include -I..   -c 
policytest.c
gcc -g -O2  -DHAVE_CONFIG_H -I./../include -I../include -I..   -c 
cfgread.c
gcc -g -O2  -DHAVE_CONFIG_H -I./../include -I../include -I..   -c 
smtpdata.c
gcc -g -O2  -DHAVE_CONFIG_H -I./../include -I../include -I..   -c 
smtpcmds.c
smtpcmds.c: In function `smtp_mail':
smtpcmds.c:908: structure has no member named `TLS'
smtpcmds.c:909: structure has no member named `TLS'
smtpcmds.c:915: structure has no member named `TLS'
smtpcmds.c:916: structure has no member named `TLS'
smtpcmds.c:952: structure has no member named `TLS'
smtpcmds.c:953: structure has no member named `TLS'
smtpcmds.c:958: structure has no member named `TLS'
smtpcmds.c:959: structure has no member named `TLS'
make[1]: *** [smtpcmds.o] Error 1
make[1]: Leaving directory `/usr/local/src/zmailer-cvs/zmailer/smtpserver'
make: *** [all] Error 1

Thanks, 

-

---

From: Matti Aarnio <[email-masked]>
Date: Mon, 7 Oct 2002 11:39:14 +0300

> zmailer CVS source build:

  Eh ?  Hmm..   Damn, when you don't have OpenSSL support
  in use, then that sub-structure isn't defined..

  My bad.  Fix is simple, and I just commmitted it into the CVS.

...
> gcc -g -O2  -DHAVE_CONFIG_H -I./../include -I../include -I..   -c smtpcmds.c
...