Subject: antivirus

From: Gilles Bouthenot <[email-masked]>
Date: Tue, 26 Feb 2002 13:54:30 +0100

Hi !
I am very new to zmailer and I must add antivirus support to our mail server.
I have chosen zmailer due to its reliabily and speed.
Unfortunaley, I found no document describing how to implement a virus scannig to the process of mail delivery. I think that the mail server has to have antivirus support.
Previously on the Mailing list, someone tells about amavis that it can be supported.

Who succedded in doing this ? Who can help me ?

Maybe amavis is a bad choice, do you know another antivirus that is more zmailer-friendly ?

Thank you.

-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Robert Kurjata <[email-masked]>
Date: Mon, 4 Mar 2002 11:13:00 +0100

Hello Gilles,

Tuesday, February 26, 2002, 1:54:30 PM, you wrote:

GB> Hi !
GB> I am very new to zmailer and I must add antivirus support to our mail server.
GB> I have chosen zmailer due to its reliabily and speed.
GB> Unfortunaley, I found no document describing how to implement a virus scannig to the process of mail delivery. I think that the mail server has to have antivirus support.
GB> Previously on the Mailing list, someone tells about amavis that it can be supported.

GB> Who succedded in doing this ? Who can help me ?

GB> Maybe amavis is a bad choice, do you know another antivirus that is more zmailer-friendly ?

GB> Thank you.

GB> -
GB> To unsubscribe from this list: send the line "unsubscribe zmailer" in
GB> the body of a message to [email-masked]

I have one instalation of zmailer with antivirus support. It uses
slightly modified emailscan script from sourceforge and Sophos sweep
antivirus. Instaleed in router script works fine, but frankly it is
not high load mailsystem, so some overhead does not mean troubles to
me.
I think any program can be used this way via router processing script,
but again it may not be the optimal way.

-- 
Best regards,
 Robert Kurjata                           mailto:[email-masked]

-

---

From: Robert Kurjata <[email-masked]>
Date: Mon, 4 Mar 2002 16:41:51 +0100

Hello Gilles,

Monday, March 04, 2002, 12:31:06 PM, you wrote:

>>but again it may not be the optimal way.

GB> Hi. And thank you for your answer.
GB> Would you be kind enough to send me your router script ? I won't make it public.
GB> This way, I may be able to implement amavis virus scanning in zmailer.

GB> Again, thank you.

Continuing the thread ......
Maybe this wasn't the best idea to use such old method (as said at
sourceforge) this project died oct,2000
(see: http://sourceforge.net/projects/emailscan )
but it worked. I just added one line to process.cf

        case "$file" in
#       [0-9]*.x400)    x400 "$file" ;;
#       [0-9]*.uucp)    uucpfilter "$file" > /tmp/X.$$
#                       cat /tmp/X.$$ > "$file"
#                       rfc822 "$file" ;;
        [0-9]*)         /bin/bash -c "/etc/emailscan/emailscan $file" || {/bin/rm -f "$file"; return; }
                        rfc822 "$file" 
                        ;;
        core*)          /bin/mv "$file" ../$file.router.$$
                        return
                        ;;
        *)              /bin/mv "$file" ../postman/rtr."$file".$$
                        return
                        ;;
        esac

-- 
Best regards,
 Robert                            mailto:[email-masked]

-