Subject: router SEGV in 'interpret.c'

From: Alexey Antipov <[email-masked]>
Date: Tue, 8 Jan 2002 15:11:16 +0300

Hallo,

We have zmailer-2.99.56-pre1 installed.

Here example config we have:
-------------------------------------
### aliases:
alias1:	[email-masked], [email-masked]

# we start to debug with combination like this:
#alias1:	[email-masked], [email-masked]
#alias2:	[email-masked]
-------------------------------------

-------------------------------------
#fqdnaliases:
[email-masked]:	[email-masked]
-------------------------------------

Router crashes with sigsegv while sending mail to [email-masked].
If duplicated address is not an fqdn alias all works properly.
Upgrade to latest cf files does not help.
Previous installed zmailer version 2.99.51 didn't crash in such configuration.
Where things go wrong???

gdb output:

Program received signal SIGSEGV, Segmentation fault.
0x806968a in interpret (Vcode=0x8116000, Veocode=0x8116fd9, Ventry=0x8116027, 
    caller=0xbfbfb534, retcodep=0xbfbfb500, cdp=0x8103580) at interpret.c:2030
2030                                      slen = strlen(name);
(gdb) bt
#0  0x806968a in interpret (Vcode=0x8116000, Veocode=0x8116fd9, 
    Ventry=0x8116027, caller=0xbfbfb534, retcodep=0xbfbfb500, cdp=0x8103580)
    at interpret.c:2030
#1  0x806b4d6 in lapply (fname=0x808e609 "crossbar", l=0x80c1a6c)
    at interpret.c:2861
#2  0x80528a2 in l_apply (fname=0x808e609 "crossbar", l=0x80c1a6c)
    at shliaise.c:28
#3  0x8053fa0 in crossbar (from=0x80d64f0, to=0x8145940) at shliaise.c:620
#4  0x8058964 in sequencer (e=0x80b3030, file=0x811a1e0 "619563")
    at rfc822.c:1975
#5  0x8054298 in run_rfc822 (argc=2, argv=0xbfbfe3f8) at rfc822.c:178
#6  0x80741c7 in execute (c=0xbfbfec84, caller=0xbfbff9c4, oretcode=0, 
    name=0x808cede "rfc822") at execute.c:393
#7  0x8067106 in runcommand (c=0xbfbfec84, pc=0xbfbff9c4, retcodep=0xbfbff990, 
    cmdname=0x808cede "rfc822") at interpret.c:760
#8  0x8068ea1 in interpret (Vcode=0x8100c00, Veocode=0x8100f46, 
    Ventry=0x8100c0f, caller=0xbfbff9c4, retcodep=0xbfbff990, cdp=0x8103640)
    at interpret.c:1799
#9  0x806b4d6 in lapply (fname=0x808c940 "process", l=0x80c5870)
    at interpret.c:2861
#10 0x806b572 in apply (argc=2, argv=0xbfbffb34) at interpret.c:2885
#11 0x8052914 in s_apply (argc=2, argv=0xbfbffb34) at shliaise.c:51
#12 0x804ab5e in main (argc=2, argv=0xbfbffbe4) at router.c:321
#13 0x804a3e5 in _start ()

--

-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Matti Aarnio <[email-masked]>
Date: Fri, 1 Feb 2002 11:44:18 +0200

> Here example config we have:

  Right.  A script error combined with code presuming that
  router will always produce valid structured LISP objects,
  e.g. scripts be error free..

  (I need softer head-thump surface....)

  CVS commit to follow latter today.

...
> Previous installed zmailer version 2.99.51 didn't crash in such configuration.

   The   bitbucket  returns in the  fqdnaliases.cf  must be
   with three parenthesis, instead of one..

-- 
/Matti Aarnio	<[email-masked]>

-