Subject: smtp 421 code

From: zmailer <[email-masked]>
Date: Wed, 11 Sep 2002 20:15:50 -0300

Hi,

we are running
ZMailer smtp (2.99.55 #1: Mon Nov  5 11:32:39 ART 2001)
but there is nothing similar in the ChangeLog.

When yahoo returns 421 the delivery is attempted
once a second 5 or 10 times until it stops
and restarts again a little later.

([email-masked] is an alias for a local user)

I think is not right...

may be it is because Pipelining is in efect and
the 421 code is not read because of the pending answers?

TIA
=====================
05594S0008605349#       (Connecting to `mta-v13.level3.mail.yahoo.com'
[64.157.4.83|25] Tue Sep 10 21:48:47 2002)
05594S0008705350r       220 YSmtp mta402.mail.yahoo.com ESMTP service ready
05594S0008805350w       EHLO dedos.pert.com.ar
05594S0008905350r       250-mta402.mail.yahoo.com
05594S0009005350r       250-8BITMIME
05594S0009105350r       250-SIZE 5242880
05594S0009205350r       250 PIPELINING
05594S0009305350#       smtpopen: status = 0
05594S0009405350w       MAIL From:<some@spammer> BODY=8BITMIME SIZE=1739
05594S0009505350w       RCPT To:<[email-masked]>
05594S0009605350w       DATA
05594S0009705350r       421 VS2-MF Excessive unknown recipients - possible
Open Relay http://help.yahoo.com/help/us/mail/spam/spam-18.html (#4.4.5)
05594S0009805350#       Remote hung up on us while 2 responses missing
05594S0009905350#        smtp_sync() did yield code 75
05594S0010005350w       RSET
05594S0010105350#       Remote hung up on us while 3 responses missing
05594S0010205350#        smtp_sync() did yield code 75
05594S0010305350#       (closed SMTP channel - after delivery failure)
05594S0010405350#       (Connecting to `mta-v12.level3.mail.yahoo.com'
[64.157.4.82|25] Tue Sep 10 21:48:48 2002)
05594S0010505351r       220 YSmtp mta467.mail.yahoo.com ESMTP service ready
05594S0010605351w       EHLO dedos.pert.com.ar
05594S0010705351r       250-mta467.mail.yahoo.com
05594S0010805351r       250-8BITMIME
05594S0010905351r       250-SIZE 5242880
05594S0011005351r       250 PIPELINING
05594S0011105351#       smtpopen: status = 0
05594S0011205351w       MAIL From:<spamer> BODY=8BITMIME SIZE=1739
05594S0011305351w       RCPT To:<[email-masked]>
05594S0011405351w       DATA
05594S0011505351r       421 VS2-MF Excessive unknown recipients - possible
Open Relay http://help.yahoo.com/help/us/mail/spam/spam-18.html (#4.4.5)

-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Ed Dyer <[email-masked]>
Date: Fri, 13 Sep 2002 16:13:22 -0300 (ADT)

In my experience once you get one or two VS2-MF codes back from
yahoo's servers, then little or no further mail is accepted by
them until the offending spam is deleted from your smtp queue. 
Once the deletion happens, then the traffic will start flowing
again as soon as an item for yahoo that is in the queue reaches
retry. 

On the other hand, if all the messages to yahoo are in
activation pending, or running now state, then I have not found
a way to recover except to restart.

Any more elegant solutions would be appreciated.

HTH

Ed Dyer
Assistant Postmaster <[email-masked]>
Chebucto Community Network

On Wed, 11 Sep 2002, zmailer wrote:

> Date: Wed, 11 Sep 2002 20:15:50 -0300
> From: zmailer <[email-masked]>
> To: [email-masked]
> Subject: smtp 421 code
> 
> Hi,
> 
> we are running

-