Subject: contentfilter

From: Eugene Crosser <[email-masked]>
Date: 23 Aug 2002 17:34:44 +0400

Matti,

I think that you might have forgotten to update or commit configure.in
which sould now contain utils/smtp-contentfilter in AC_OUTPUT

Eugene

-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Matti Aarnio <[email-masked]>
Date: Fri, 23 Aug 2002 17:51:32 +0300

> which sould now contain utils/smtp-contentfilter in AC_OUTPUT

  Oh, right you are..  Now if I could squeeze time into processing
  my zmailer patch backlog..

> Eugene

/Matti Aarnio
-

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Fri, 23 Aug 2002 20:40:21 +0530

Hi,

zmailer tries to fix up quite a bit of brokenness, including 8-bit text 
in the headers. Unsurprisingly, a program isn't able to fix all the 
problems caused by other programs. To test one case:

telnet localhost 25
...
data
354 Start mail input; end with <CRLF>.<CRLF>
From: Arnt Gulbrandsen <[email-masked]>
Subject: test with ü
Cc: ue ü <[email-masked]>
To: ue "ü" <[email-masked]>

Test.
.
250 2.6.0 S280103AbSHWPDl message accepted

The result looked like this (only the relevant fields shown):

Subject: test with =?ISO-8859-1?Q?=FC?=
Cc: ue =?ISO-8859-1?Q?=FC?= <[email-masked]>
To: ue =?ISO-8859-1?Q?"=FC"?= <[email-masked]>

That To field isn't legal. 2047 section 5(3) says " can't be used in an 
encoded-word in a to field.

I'm not going to call it a bug, and I wouldn't fix it. IMO it's a case 
of GIGO. However, others may disagree.

--Arnt
-

---

From: Matti Aarnio <[email-masked]>
Date: Fri, 23 Aug 2002 18:37:04 +0300

> problems caused by other programs. To test one case:

  Yeah, it is borderline crazy thing to fix..
  Anyway I added the one comparison fix into there, although
  it really isn't a) at a sane place, b) sane code...
  (The header MIME encoder should be inside the router at header
   write-out, not in the transport-agents..)

-- 
/Matti Aarnio	<[email-masked]>
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]