Subject: Enabling PAM for AUTH

From: "Luke Galea" <[email-masked]>
Date: Fri, 27 Sep 2002 16:55:45 -0400

I have been trying to figure out how to enable the use of PAM for
SMTP-AUTH.
I found the guide, but it doesn't seem to provide enough information. I
realize how to configure PAM once zmailer is using it, but how do I go
about making zmailer use PAM for authentication?

Thanks in advance.

Luke Galea 
Software Development
BlueCat Networks
905-762-5225
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Matti Aarnio <[email-masked]>
Date: Sat, 28 Sep 2002 00:12:49 +0300

On Fri, Sep 27, 2002 at 04:55:45PM -0400, Luke Galea wrote:
> SMTP-AUTH.   I found the guide, but it doesn't seem to provide
> enough information. I realize how to configure PAM once zmailer
> is using it, but how do I go about making zmailer use PAM for
> authentication?

  In pre-compilation time (configuration) there is option:
      --disable-pam

  If you don't have that defined, and have   <security/pam_appl.h>
  header file, then your system is compiled with PAM support.
  Oh.. and is linked with "-lpam" library while making smtpserver.

  After that, this file (that you found about) is needed in the system:

       ------- /etc/pam.d/smtpauth-login -----------

       #%PAM-1.0
       auth     required  /lib/security/pam_pwdb.so shadow
       auth     required  /lib/security/pam_nologin.so
       account  required  /lib/security/pam_pwdb.so

  (Just those four lines, not the preceeding filename line)

  However this file recipe is positively known to work only
  at Linux (RedHat's at least), and Solaris.  I recall that
  HP-UX and perhaps AIX might also have PAM support.
  Are there possibly some different paths needed in
  that case, that I don't know...

  You didn't mention your system environment.

-- 
/Matti Aarnio	<[email-masked]>
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]