Subject: Contentfilter problem

From: Adrian Siemieniak <[email-masked]>
Date: Wed, 9 Oct 2002 14:34:57 +0200

Hi

For few days (after reboot and quite big system upgrade) i have problem
with contentfilter - i'v tried so many things to do that i'v already
lost myself

smtpserver.conf has few lines like below
---
PARAM  policydb   $DBTYPE  $MAILVAR/db/smtp-policy
#
# External program for received message content analysis:
PARAM  contentfilter    /sav/bin/tst
----

tst is a shell script that check mails against viruses - it returns 0 or
-1. Whatever i do - even if i change that tst to simple C program that
writes to stdout "0" i get in logs stuff like here
---
HWP009672r      data
HWP009672w      354 Start mail input; end with <CRLF>.<CRLF>
HWP009672#      policyprogram said: ˙
HWP009672#      policyprogram said: 
HWP009672#      Content-policy analysis ordered message rejection.
(code=-1); ms g=''
HWP009672w      552 5.7.1 
---

And i'm preate sure that 'tst' sais "0" . Where to look for solution -
i'm getting creazy with it.

Howgh!
--
Adrian Siemieniak | Administrator (at) Internet Center Polska
sauron(at)icenter.pl
tel. (0-71) 344-82-53 wew 26
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Matti Aarnio <[email-masked]>
Date: Wed, 9 Oct 2002 16:12:26 +0300

> with contentfilter - i'v tried so many things to do that i'v already

  Check  README.UPGRADING -- I did change the smtpserver <-> smtp-policy
  communication protocol to fix couple troubles I had.
  There is the diff you need to make to get this thing to work.

> HWP009672#      policyprogram said: ?

-- 
/Matti Aarnio	<[email-masked]>
FUNET:  Finnish Academic and Research Network
	Network Information/Software Archival Service
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]