Subject: zmailer and quotas

From: XosÉ Vázquez <[email-masked]>
Date: Sun, 13 Jan 2002 00:12:27 +0100

hello to all,

I have a compilation problem with zmailer CVS or 2.99.55-p1 and quotas 
with the configure option --with-mboxquotacheck

--cortamorena--
make[3]: Leaving directory `/home/xose/rpmbuild/BUILD/zmailer-2.99.56/transports/mailbox'
cc -O2 -march=i386 -mcpu=i686  -DHAVE_CONFIG_H -I./../../include -I../../include -I../..    -c -o version.o version.c
cc -O2 -march=i386 -mcpu=i686  -DHAVE_CONFIG_H -I./../../include -I../../include -I../..  -DBIFF -DRBIFF -DRBIFF_ALWAYS  -c ./lock.c
cc -O2 -march=i386 -mcpu=i686  -DHAVE_CONFIG_H -I./../../include -I../../include -I../..  -DBIFF -DRBIFF -DRBIFF_ALWAYS  -c ./sieve.c
cc -O2 -march=i386 -mcpu=i686  -DHAVE_CONFIG_H -I./../../include -I../../include -I../..  -DBIFF -DRBIFF -DRBIFF_ALWAYS  -c ./fmtmbox.c
cc -O2 -march=i386 -mcpu=i686  -DHAVE_CONFIG_H -I./../../include -I../../include -I../..  -o mailbox mailbox.o version.o lock.o sieve.o fmtmbox.o -L../../libs -lta -lzm -lzc -lsfio -lcrypt  -lresolv
mailbox.o: In function `deliver':
mailbox.o(.text+0x1b07): undefined reference to `checkmbsize'
collect2: ld returned 1 exit status
make[2]: *** [mailbox] Error 1
make[2]: Leaving directory `/home/xose/rpmbuild/BUILD/zmailer-2.99.56/transports/mailbox'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/home/xose/rpmbuild/BUILD/zmailer-2.99.56/transports'
make: *** [all] Error 1
--sacabo--

regards,
-
To unsubscribe from this list: send the line "unsubscribe zmailer" in
the body of a message to [email-masked]

---

From: Eugene Crosser <[email-masked]>
Date: Mon, 14 Jan 2002 15:23:00 +0300 (MSK)

> with the configure option --with-mboxquotacheck

You need to make a function checkmbsize() that implements the actual
check of mailbox quata for the user, and make it available somewhere
in --with-generic-lib= list.  Sorry, I guess I must contribute some
documentation on this feature.  By now, see the source of mailbox.c
for details.

Eugene

-